Pocket System Requirements

If you're wondering if Pocket will work on your computer or mobile device, please refer to the following guidelines:

Pocket for iOS

Pocket will work great on any iPhone, iPad and iPod Touch running iOS 11 above. If you're not certain what version of iOS your device is running, open Settings, and tap General > About.

Pocket for Android

Pocket is compatible with any Android device running Android version 4.1 or above. If you are wondering what version is installed on your device, open Settings, tap About phone/tablet, and look for Android Version.

Pocket Web App

The Pocket Web App is compatible with Mozilla Firefox, Google Chrome, Safari, Opera, Microsoft Edge, and likely other modern browsers.

Pocket Browser Extensions

There are Pocket extensions available for Google Chrome, Safari, Microsoft Edge, Opera, and Yandex. We recommend that you keep your browsers up to date to ensure that you have the best experience.

For Firefox users, Pocket is integrated into Firefox starting with version 38.0.5.

Pocket for Kindle Fire

Pocket is compatible with most Kindle Fire devices from 2013 and later.

Pocket for Mac

Pocket for Mac requires macOS El Capitan (10.11) and later.

Frequently Asked Questions

Will Pocket be compatible with my older device?

There are a number technical limitations that prevent us from being compatible on older devices or operating systems. Therefore, we do not have plans to make Pocket available for legacy devices at this time.

Still need help? Contact Pocket Support Contact Pocket Support